Open |
This class contains options available for opening a document from disk.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The OpenOptions type exposes the following members.

Name | Description | |
---|---|---|
![]() | OpenOptions | Constructs a new instance of the options class using default values. |

Name | Description | |
---|---|---|
![]() | AllowOpeningLocalByWrongUser | Specifies whether a local file is allowed to be opened as read-only by a user other than its owner. |
![]() | Audit | Specifies whether to expand all elements in order to check for corruption. |
![]() | DetachFromCentralOption | An option that specifies whether or not a workset-enabled document is detached from its central document. |
![]() | IgnoreExtensibleStorageSchemaConflict | Specifies whether to ignore the error of schema conflict. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | OpenForeignOption | An option that specifies how to open files saved by an application that was not developed or licensed by Autodesk. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the OpenOptions |
![]() | GetOpenWorksetsConfiguration | Gets the object used to configure the worksets to open when the model is opened. |
![]() ![]() | SetOpenWorksetsConfiguration | Sets the object used to configure the worksets to open when the model is opened. |