OpenOptions Class


Open Options Class

This class contains options available for opening a document from disk.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB OpenOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class OpenOptions : IDisposable

The OpenOptions type exposes the following members.

Constructors
Name Description
Public method OpenOptions Constructs a new instance of the options class using default values.
Top
Properties
Name Description
Public property AllowOpeningLocalByWrongUser Specifies whether a local file is allowed to be opened as read-only by a user other than its owner.
Public property Audit Specifies whether to expand all elements in order to check for corruption.
Public property DetachFromCentralOption An option that specifies whether or not a workset-enabled document is detached from its central document.
Public property IgnoreExtensibleStorageSchemaConflict Specifies whether to ignore the error of schema conflict.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property OpenForeignOption An option that specifies how to open files saved by an application that was not developed or licensed by Autodesk.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the OpenOptions
Public method GetOpenWorksetsConfiguration Gets the object used to configure the worksets to open when the model is opened.
Public method Code example SetOpenWorksetsConfiguration Sets the object used to configure the worksets to open when the model is opened.
Top
See Also