BRepBuilderSurfaceGeometry Class


BRep Builder Surface Geometry Class

An abstract class used by BRepBuilder to represent the geometry of a surface. Specific surface-geometry representations are represented by subclasses.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BRepBuilderSurfaceGeometry

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class BRepBuilderSurfaceGeometry : IDisposable

The BRepBuilderSurfaceGeometry type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Static member Create Construct BRepBuilderSurfaceGeometry based on a permitted Revit Surface.
Public method Static member CreateNURBSSurface(Int32, Int32, IList Double , IList Double , IList XYZ , Boolean, BoundingBoxUV) Construct a BRepBuilderSurfaceGeometry based on NURBS surface data, where the weights are not supplied. In this case, the NURBS surface will be a piecewise polynomial surface.
Public method Static member CreateNURBSSurface(Int32, Int32, IList Double , IList Double , IList XYZ , IList Double , Boolean, BoundingBoxUV) Construct BRepBuilderSurfaceGeometry based on NURBS surface data, where the weights are supplied. In this case, the NURBS surface will be a piecewise rational polynomial surface.
Public method Dispose Releases all resources used by the BRepBuilderSurfaceGeometry
Top
See Also