SaveAsFabricationJob Method


Fabrication Part Save As Fabrication Job Method

Save fabrication parts to an MEP job that can be opened in the fabrication software.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ISet<ElementId> SaveAsFabricationJob(
	Document document,
	ISet<ElementId> ids,
	string filename,
	FabricationSaveJobOptions saveOptions
)

Parameters

document Document
The document.
ids ISet ElementId
List of element Ids of fabrication parts or assemblies and group elements that contain fabrication parts to save. Non-fabrication part elements will be ignored.
filename String
The full path and filename of the fabrication job to save.
saveOptions FabricationSaveJobOptions
Options for the save operation.

Return Value

ISet ElementId
Returns a list of fabrication part element Ids that were saved to the fabrication job.
Exceptions
Exception Condition
ArgumentException Fabrication configuration is missing.
ArgumentNullException A non-optional argument was null
InvalidOperationException the path to the filename must already exist and be writeable
InvalidPathArgumentException The destination file name includes one or more invalid characters.
Remarks
Only fabrication MAJ files are supported.
See Also