Rectangle Class |
Stores a set of four integers that represent the left, top, right and bottom of a rectangle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The Rectangle type exposes the following members.

Name | Description | |
---|---|---|
![]() | Rectangle | Create an empty Rectangle instance with values (0,0,0,0). |
![]() | Rectangle(Rectangle) | Constructs a new copy of the input ScreenRectangle object. |
![]() | Rectangle(Int32, Int32, Int32, Int32) | Creates an Rectangle instance with the specified four integers that represent the left, top, right and bottom of a rectangle. |

Name | Description | |
---|---|---|
![]() | Bottom | The y-coordinate of the bottom-right corner of the rectangle. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | Left | The x-coordinate of the top-left corner of the rectangle. |
![]() | Right | The x-coordinate of the bottom-right corner of the rectangle. |
![]() | Top | The y-coordinate of the top-left corner of the rectangle. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the Rectangle |
![]() | IsNormalized | Returns true if the rectangle coordinates are normalized to the screen coordinate space; that is, left is less than right and top is less than bottom. |

It usually represents a rectangle on the screen. Left must be less than right and top must be less than bottom.