Rectangle Class


Rectangle Class

Stores a set of four integers that represent the left, top, right and bottom of a rectangle.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB Rectangle

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class Rectangle : IDisposable

The Rectangle type exposes the following members.

Constructors
Name Description
Public method Rectangle Create an empty Rectangle instance with values (0,0,0,0).
Public method Rectangle(Rectangle) Constructs a new copy of the input ScreenRectangle object.
Public method Rectangle(Int32, Int32, Int32, Int32) Creates an Rectangle instance with the specified four integers that represent the left, top, right and bottom of a rectangle.
Top
Properties
Name Description
Public property Bottom The y-coordinate of the bottom-right corner of the rectangle.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Left The x-coordinate of the top-left corner of the rectangle.
Public property Right The x-coordinate of the bottom-right corner of the rectangle.
Public property Top The y-coordinate of the top-left corner of the rectangle.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the Rectangle
Public method IsNormalized Returns true if the rectangle coordinates are normalized to the screen coordinate space; that is, left is less than right and top is less than bottom.
Top
Remarks
It usually represents a rectangle on the screen. Left must be less than right and top must be less than bottom.
See Also