GetNumBuildingStoreys Method


Exporter IFCUtils Get Num Building Storeys Method

Returns the number of non-empty, non-duplicate building stories in the file.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static int GetNumBuildingStoreys(
	ExporterIFC exporterIFC
)

Parameters

exporterIFC ExporterIFC
The exporter.

Return Value

Int32
The number of stories.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also