GetNumBuildingStoreys Method


Exporter IFCUtils Get Num Building Storeys Method

Note: This API is now obsolete.

Returns the number of non-empty, non-duplicate building stories in the file.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
[ObsoleteAttribute("This is deprecated in Revit 2026.  Use ExporterCacheManager.LevelInfoCache.LevelsById.Count instead.")]
public static int GetNumBuildingStoreys(
	ExporterIFC exporterIFC
)

Parameters

exporterIFC ExporterIFC
The exporter.

Return Value

Int32
The number of stories.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also