Material |
This class represents a change of material during a model-exporting process.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The MaterialNode type exposes the following members.

Name | Description | |
---|---|---|
![]() | Color | The color the material is being rendered at |
![]() | Glossiness | The level of glossiness of the material |
![]() | HasOverriddenAppearance | Identifies if the default rendering appearance the material has is being overridden. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode ) |
![]() | MaterialId | The Id of the element assocated with this material in the model. |
![]() | NodeName | A readable name of the output node. (Inherited from RenderNode ) |
![]() | Smoothness | The level of smoothness of the material. |
![]() | ThumbnailFile | The path if a file that contains a thumbnail image of the material. |
![]() | Transparency | The value of transparency the material is being rendered with |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from RenderNode ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetAppearance | Appearance properties associated with the material. |
![]() | GetAppearanceOverride | Returns appearance properties that override the preset appearance of the material. |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

Output nodes following this node are to be assumed using the material. The material remains in effect until another material node is sent to the output.
See also: OnMaterial(MaterialNode) .