MaterialNode Class


Material Node Class

This class represents a change of material during a model-exporting process.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB RenderNode
Autodesk.Revit.DB MaterialNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class MaterialNode : RenderNode

The MaterialNode type exposes the following members.

Properties
Name Description
Public property Color The color the material is being rendered at
Public property Glossiness The level of glossiness of the material
Public property HasOverriddenAppearance Identifies if the default rendering appearance the material has is being overridden.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RenderNode )
Public property MaterialId The Id of the element assocated with this material in the model.
Public property NodeName A readable name of the output node.
(Inherited from RenderNode )
Public property Smoothness The level of smoothness of the material.
Public property ThumbnailFile The path if a file that contains a thumbnail image of the material.
Public property Transparency The value of transparency the material is being rendered with
Top
Methods
Name Description
Public method Dispose
(Inherited from RenderNode )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetAppearance Appearance properties associated with the material.
Public method GetAppearanceOverride Returns appearance properties that override the preset appearance of the material.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks

Output nodes following this node are to be assumed using the material. The material remains in effect until another material node is sent to the output.

See also: [!:Autodesk::Revit::DB::IExportContext::OnMaterial] .

See Also