CloudPoint Structure


Cloud Point Structure

Represents a point obtained from a Point cloud.
Inheritance Hierarchy
System Object
System ValueType
Autodesk.Revit.DB.PointClouds CloudPoint

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public struct CloudPoint

The CloudPoint type exposes the following members.

Constructors
Name Description
Public method CloudPoint Creates a new cloud point.
Top
Methods
Name Description
Public method Equals Indicates whether this instance and a specified object are equal.
(Inherited from ValueType )
Public method GetHashCode Returns the hash code for this instance.
(Inherited from ValueType )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns the fully qualified type name of this instance.
(Inherited from ValueType )
Top
Operators
Name Description
Public operator Static member (CloudPoint to XYZ) Creates an XYZ object from this point cloud.
Top
Fields
Name Description
Public field Color The color
Public field X The X coordinate
Public field Y The Y coordinate
Public field Z The Z coordinate
Top
See Also