IFCCategory |
Import mapping template from a text file.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static IFCCategoryTemplate ImportFromFile(
Document document,
string fileName,
string templateName
)
Parameters
- document Document
- A Revit document.
- fileName String
- A full text file name.
- templateName String
- A mapping template name.
Return Value
IFCCategoryTemplateThe mapping template element.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
FileAccessException | Failed to access the text file. |
InvalidOperationException | Failed to create IFCCategoryTemplate element. |