IFCCategory
|
Import mapping template from a text file.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

public static IFCCategoryTemplate ImportFromFile(
Document document,
string fileName,
string templateName
)
Parameters
- document Document
- A Revit document.
- fileName String
- A full text file name.
- templateName String
- A mapping template name.
Return Value
IFCCategoryTemplateThe mapping template element.

Exception | Condition |
---|---|
ArgumentException | The name already exists. |
ArgumentNullException | A non-optional argument was null |
FileAccessException | Failed to access the text file. |
InvalidOperationException | Failed to create IFCCategoryTemplate element. |

The imported template is saved in the document passed as parameter.
The active template of the document remains unchanged.