Item |
The ItemFactoryBase object is used to create new instances of elements within the Autodesk Revit document.

System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.Creation ItemFactoryBase
Autodesk.Revit.Creation Document
Autodesk.Revit.Creation FamilyItemFactory
Autodesk.Revit.DB APIObject
Autodesk.Revit.Creation ItemFactoryBase
Autodesk.Revit.Creation Document
Autodesk.Revit.Creation FamilyItemFactory
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The ItemFactoryBase type exposes the following members.

Name | Description | |
---|---|---|
![]() ![]() | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject ) |

Name | Description | |
---|---|---|
![]() | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | NewAlignment | Add a new locked alignment into the Autodesk Revit document. |
![]() | NewDetailCurve | Creates a new detail curve element. |
![]() | NewDetailCurveArray | Creates an array of new detail curve elements. |
![]() ![]() | NewDimension(View, Line, ReferenceArray) | Creates a new linear dimension object using the default dimension style. |
![]() | NewDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension style. |
![]() ![]() | NewFamilyInstance(Face, Line, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol. |
![]() ![]() | NewFamilyInstance(Line, FamilySymbol, View) | Add a line based detail family instance into the Autodesk Revit document, using an line and a view where the instance should be placed. |
![]() ![]() | NewFamilyInstance(Reference, Line, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a line on that face for its position, and a type/symbol. |
![]() | NewFamilyInstance(XYZ, FamilySymbol, StructuralType) | Inserts a new instance of a family into the document, using a location and a type/symbol. |
![]() | NewFamilyInstance(XYZ, FamilySymbol, View) | Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed. |
![]() ![]() | NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol. |
![]() ![]() | NewFamilyInstance(Reference, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a location, reference direction, and a type/symbol. |
![]() ![]() | NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the host element. |
![]() | NewFamilyInstance(XYZ, FamilySymbol, Level, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the level. |
![]() ![]() | NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction. |
![]() ![]() | NewFamilyInstances2 | Creates Family instances within the document. |
![]() ![]() | NewGroup | Creates a new type of group. |
![]() ![]() | NewModelCurve | Creates a new model line element. |
![]() | NewModelCurveArray | Creates an array of new model line elements. |
![]() ![]() | NewReferencePlane | Creates a new instance of ReferencePlane. |
![]() ![]() | NewReferencePlane2 | Creates a new instance of ReferencePlane. |
![]() | PlaceGroup | Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

The ItemFactoryBase object is a utility object that is used to create new instances of elements within the Autodesk Revit document. This class holds common methods used in both project documents and family documents.