ItemFactoryBase Class


Item Factory Base Class

The ItemFactoryBase object is used to create new instances of elements within the Autodesk Revit document.
Inheritance Hierarchy

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ItemFactoryBase : APIObject

The ItemFactoryBase type exposes the following members.

Properties
Name Description
Public property IsReadOnly Identifies if the object is read-only or modifiable.
(Inherited from APIObject )
Top
Methods
Name Description
Public method Dispose Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method NewAlignment Add a new locked alignment into the Autodesk Revit document.
Public method NewDetailCurve Creates a new detail curve element.
Public method NewDetailCurveArray Creates an array of new detail curve elements.
Public method NewDimension(View, Line, ReferenceArray) Creates a new linear dimension object using the default dimension style.
Public method NewDimension(View, Line, ReferenceArray, DimensionType) Creates a new linear dimension object using the specified dimension style.
Public method NewFamilyInstance(Face, Line, FamilySymbol) Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol.
Public method NewFamilyInstance(Line, FamilySymbol, View) Add a line based detail family instance into the Autodesk Revit document, using an line and a view where the instance should be placed.
Public method NewFamilyInstance(Reference, Line, FamilySymbol) Inserts a new instance of a family onto a face referenced by the input Reference instance, using a line on that face for its position, and a type/symbol.
Public method NewFamilyInstance(XYZ, FamilySymbol, StructuralType) Inserts a new instance of a family into the document, using a location and a type/symbol.
Public method NewFamilyInstance(XYZ, FamilySymbol, View) Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed.
Public method NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol.
Public method NewFamilyInstance(Reference, XYZ, XYZ, FamilySymbol) Inserts a new instance of a family onto a face referenced by the input Reference instance, using a location, reference direction, and a type/symbol.
Public method NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) Inserts a new instance of a family into the document, using a location, type/symbol, and the host element.
Public method NewFamilyInstance(XYZ, FamilySymbol, Level, StructuralType) Inserts a new instance of a family into the document, using a location, type/symbol, and the level.
Public method NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction.
Public method NewFamilyInstances2
Public method NewGroup
Public method NewModelCurve Creates a new model line element.
Public method NewModelCurveArray Creates an array of new model line elements.
Public method NewReferencePlane Creates a new instance of ReferencePlane.
Public method NewReferencePlane2 Creates a new instance of ReferencePlane.
Public method PlaceGroup Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
The ItemFactoryBase object is a utility object that is used to create new instances of elements within the Autodesk Revit document. This class holds common methods used in both project documents and family documents.
See Also