IndexPoint Class


Index Point Class

A point primitive consisting of one index.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.DirectContext3D IndexPrimitive
Autodesk.Revit.DB.DirectContext3D IndexPoint

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class IndexPoint : IndexPrimitive

The IndexPoint type exposes the following members.

Constructors
Name Description
Public method IndexPoint Constructs the point primitive.
Top
Properties
Name Description
Public property Index The index of the point's vertex.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from IndexPrimitive )
Top
Methods
Name Description
Public method Dispose
(Inherited from IndexPrimitive )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method Static member GetSizeInShortInts Gets the amount of storage that the primitive takes up in a buffer, measured in short integers.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also