DirectShapeTypeOptions Class


Direct Shape Type Options Class

This class is used to control behavior of a DirectShapeType object.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB DirectShapeTypeOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DirectShapeTypeOptions : IDisposable

The DirectShapeTypeOptions type exposes the following members.

Constructors
Name Description
Public method DirectShapeTypeOptions Constructs a new DirectShapeTypeOptions instance with default settings.
Top
Properties
Name Description
Public property AllowDuplicateNames Determines whether or not duplicate DirectShapeType names are allowed.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the DirectShapeTypeOptions
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method IsEqualTo Compare this object with the one supplied as argument. Return true if the options specified by both objects are the same.
Public method IsValid Determines whether a DirectShapeTypeOptions is internally consistent (valid).
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
Use Enable/Disable functions to change the default behavior. Use DirectShapeType.SetOptions to modify that object's behavior.
See Also