DirectShapeTypeOptions Class


Direct Shape Type Options Class

This class is used to control behavior of a DirectShapeType object.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB DirectShapeTypeOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DirectShapeTypeOptions : IDisposable

The DirectShapeTypeOptions type exposes the following members.

Constructors
Name Description
Public method DirectShapeTypeOptions Constructs a new DirectShapeTypeOptions instance with default settings.
Top
Properties
Name Description
Public property AllowDuplicateNames Determines whether or not duplicate DirectShapeType names are allowed.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the DirectShapeTypeOptions
Public method IsEqualTo Compare this object with the one supplied as argument. Return true if the options specified by both objects are the same.
Public method IsValid Determines whether a DirectShapeTypeOptions is internally consistent (valid).
Top
Remarks
Use Enable/Disable functions to change the default behavior. Use DirectShapeType.SetOptions to modify that object's behavior.
See Also