Direct |
This class is used to control behavior of a DirectShapeType object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The DirectShapeTypeOptions type exposes the following members.

Name | Description | |
---|---|---|
![]() | DirectShapeTypeOptions | Constructs a new DirectShapeTypeOptions instance with default settings. |

Name | Description | |
---|---|---|
![]() | AllowDuplicateNames | Determines whether or not duplicate DirectShapeType names are allowed. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the DirectShapeTypeOptions |
![]() | IsEqualTo | Compare this object with the one supplied as argument. Return true if the options specified by both objects are the same. |
![]() | IsValid | Determines whether a DirectShapeTypeOptions is internally consistent (valid). |

Use Enable/Disable functions to change the default behavior. Use DirectShapeType.SetOptions to modify that object's behavior.