Failures |
Checks if resolution of the failures by deleting given collection of elements is permitted.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public bool IsElementsDeletionPermitted(
IList<ElementId> idsToDelete,
out string reason
)
Parameters
- idsToDelete IList ElementId
- The Ids of elements to be deleted.
- reason String
- A localized string explaining reason why the elements cannot be deleted.
Return Value
BooleanTrue if resolution of the failures by deleting given elements is permitted

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing). |

Method does not confirm if deletion of the elements will or may resolve the failure - it simply verifies that given elements can be deleted in the current state of the document.