PanelScheduleData Class


Panel Schedule Data Class

The PanelScheduleData class holds most of the data that describe the layout, appearance, and style of the rows, columns, and cells of a panel schedule
Inheritance Hierarchy
System Object
Autodesk.Revit.DB TableData
Autodesk.Revit.DB.Electrical PanelScheduleData

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PanelScheduleData : TableData

The PanelScheduleData type exposes the following members.

Properties
Name Description
Public property BodyShowsVerticalHeaders Shows text in the Load Summary section's headers vertically instead of horizontally
Public property BorderAroundSchedule Places a border (GraphicStyle element) around the entire schedule, visible only on the instance and sheet
Public property BorderAroundSections Places a border (GraphicStyle element) around each section, visible only on the instance and sheet
Public property IsAutoShadingForLoadDisplay Display shading of load cells automatically or not.
Public property IsFooterSectionHidden True if the user wishes to hide the footer section; setting this value must go through the appropriate update function
Public property IsHeaderSectionHidden True if the user wishes to hide the header section; setting this value must go through the appropriate update function
Public property IsPanelSinglePhase Identifies if the panel is single phase.
Public property IsSummarySectionHidden True if the user wishes to hide the summary section; setting this value must go through the appropriate update function
Public property IsUnusedPhaseHidden True if the user wishes to hide the unused phase column of a single phase panel, false otherwise.
Public property NumberOfSlots The number of slots in the panel schedule; setting this value must go through the appropriate update function
Public property PanelConfiguration The panel configuration of this panel schedule
Public property PhaseLoadType This property determines the layout of the phase load columns; setting this value must go through the updateCircuitTable function
Public property PhasesAsCurrents If true, the phase columns are currents (A), otherwise they are loads (VA); setting this value must go through the appropriate update function
Public property ScheduleType The panel schedule type of this panel schedule
Public property ShowCircuitNumberOnOneRowForMultiphaseCircuits Shows the circuit number broken up on each row of the multiphase circuit rows if true, all on the first row otherwise
Public property ShowMultipleRowsForMultiphaseCircuits shows extra rows below multiphase circuits to indicate how many slots they take up if true, all on a single row otherwise
Public property ShowSlotFromDeviceInsteadOfTemplate When true, the number of rows in an instance will be the number of poles on the associated device, not a set number
Public property SummaryShowsGroups Show groups of load classifications in the load summary section
Public property SummaryShowsOnlyConnectedLoads Show only the connected load classifications in the summary section
Public property SummaryShowsVerticalHeaders Shows text in the Load Summary section's headers vertically instead of horizontally
Top
Methods
Name Description
Public method AddLoadClassification Add a Load Classification Id to the array of Load Classifications.
Public method GetLoadClassifications Gets an array of the load classifications associated with this panel schedule
Public method GetNumberOfCircuitRows Gets the number of rows in the circuit table
Public method IsSymmetric Check if this panel schedule is symmetric
Public method RemoveLoadClassification Remove a Load Classification Id from the array of Load Classifications
Public method SetBorderAroundSchedule Adds a border around the schedule
Public method SetBorderAroundSections Adds a border around the sections
Public method SetLoadClassifications Sets the Load Classifications associated with this panel schedule
Public method UpdateCircuitTableForInstance Redraw the circuit table for the given panel with the given parameter updates
Public method UpdateCircuitTableForTemplate Redraw the circuit table for a template with the given parameter updates
Public method UpdateIsSectionHidden Update if this section is hidden or not
Public method UpdateLoadSummary Update the load summary section
Public method UpdateVerticalHeadersInSection Sets if this header should have vertical text
Top
See Also