Wall Create(Document, IList Curve , Boolean) Method |
Creates a non rectangular profile wall within the project using the default wall type.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- document Document
- The document in which the new wall is created.
- profile IList Curve
- An array of planar curves that represent the vertical profile of the wall.
- structural Boolean
- If set, specifies that the wall is structural in nature.
Return Value
WallIf successful a new wall object within the project.

Exception | Condition |
---|---|
ArgumentException | The input profile contains at least one helical curve and is not supported for this operation. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | Failed to create the wall. |
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
ModificationOutsideTransactionException | The document has no open transaction. |