CurveElementFilter Class


Curve Element Filter Class

A filter used to pass curve elements which are of a specific type.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class CurveElementFilter : ElementSlowFilter

The CurveElementFilter type exposes the following members.

Constructors
Name Description
Public method CurveElementFilter(CurveElementType) Constructs a new instance of a filter to match specific types of curve elements.
Public method CurveElementFilter(CurveElementType, Boolean) Constructs a new instance of a filter to match specific types of curve elements, with the option to match all curves which are not of the given curve type.
Top
Properties
Name Description
Public property CurveElementType The curve element type.
Top
Methods
Name Description
Top
Example
// Create a CurveElement filter to find CurveByPoints elements.
// It is necessary to use the CurveElementFilter, and not an ElementClassFilter or  the shortcut 
// method OfClass() because subclasses of CurveElement are not supported by those methods.
CurveElementFilter filter = new CurveElementFilter(CurveElementType.CurveByPoints);

// Apply the filter to the elements in the active document
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> founds = collector.WherePasses(filter).ToElements();


// Find all curve elements: use inverted filter with invalid CurveElementType to match elements
CurveElementFilter notCurveByPntFilter = new CurveElementFilter(CurveElementType.Invalid, true); // inverted filter
collector = new FilteredElementCollector(document);
ICollection<Element> notCurveByPntFounds = collector.WherePasses(notCurveByPntFilter).ToElements();
See Also