CurveElementFilter Class


Curve Element Filter Class

A filter used to pass curve elements which are of a specific type.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ElementFilter
Autodesk.Revit.DB ElementSlowFilter
Autodesk.Revit.DB CurveElementFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class CurveElementFilter : ElementSlowFilter

The CurveElementFilter type exposes the following members.

Constructors
Name Description
Public method CurveElementFilter(CurveElementType) Constructs a new instance of a filter to match specific types of curve elements.
Public method CurveElementFilter(CurveElementType, Boolean) Constructs a new instance of a filter to match specific types of curve elements, with the option to match all curves which are not of the given curve type.
Top
Properties
Name Description
Public property CurveElementType The curve element type.
Top
Methods
Name Description
Top
See Also