Frame Class |
A Frame comprises three vectors at a base point in 3D space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The Frame type exposes the following members.

Name | Description | |
---|---|---|
![]() | Frame | Default constructor. Uses global origin and standard basis vectors. |
![]() | Frame(XYZ, XYZ, XYZ, XYZ) | Constructor that takes the frame's base point and three basis vectors. |

Name | Description | |
---|---|---|
![]() | BasisX | The first basis vector of the frame. |
![]() | BasisY | The second basis vector of the frame. |
![]() | BasisZ | The third basis vector of the frame. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | Origin | The frame's base point. |

Name | Description | |
---|---|---|
![]() ![]() | CanDefineRevitGeometry | Tests whether the supplied Frame object may be used to define a Revit curve or surface. In order to satisfy the requirements the Frame must be orthonormal and its origin is expected to lie within the Revit design limits IsWithinLengthLimits(XYZ) . |
![]() | Dispose | Releases all resources used by the Frame |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | IsOrthogonal | Determines if this frame's basis vectors are orthogonal. |
![]() | IsOrthonormal | Determines if this frame's basis vectors are orthonormal. |
![]() | IsRightHanded | Determine if this frame's basis is right-handed. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |
![]() | Transform | Applies the input transform to this frame. |

A Frame consists of three vectors at a base point in 3D space. The vectors need not be orthogonal, have unit length, or even be linearly independent, although in practice Frames will usually have linearly independent vectors. Frames may be used to represent a coordinate frame of reference, a moving frame field on a curve, or for other purposes.