Frame Class


Frame Class

A Frame comprises three vectors at a base point in 3D space.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB Frame

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class Frame : IDisposable

The Frame type exposes the following members.

Constructors
Name Description
Public method Frame Default constructor. Uses global origin and standard basis vectors.
Public method Frame(XYZ, XYZ, XYZ, XYZ) Constructor that takes the frame's base point and three basis vectors.
Top
Properties
Name Description
Public property BasisX The first basis vector of the frame.
Public property BasisY The second basis vector of the frame.
Public property BasisZ The third basis vector of the frame.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Origin The frame's base point.
Top
Methods
Name Description
Public method Static member CanDefineRevitGeometry Tests whether the supplied Frame object may be used to define a Revit curve or surface. In order to satisfy the requirements the Frame must be orthonormal and its origin is expected to lie within the Revit design limits IsWithinLengthLimits(XYZ) .
Public method Dispose Releases all resources used by the Frame
Public method IsOrthogonal Determines if this frame's basis vectors are orthogonal.
Public method IsOrthonormal Determines if this frame's basis vectors are orthonormal.
Public method IsRightHanded Determine if this frame's basis is right-handed.
Public method Transform Applies the input transform to this frame.
Top
Remarks
A Frame consists of three vectors at a base point in 3D space. The vectors need not be orthogonal, have unit length, or even be linearly independent, although in practice Frames will usually have linearly independent vectors. Frames may be used to represent a coordinate frame of reference, a moving frame field on a curve, or for other purposes.
See Also