AreOptionsValid Method


Direct Shape Are Options Valid Method

Validates that the given DirectShapeOptions are allowed for this particular DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool AreOptionsValid(
	DirectShapeOptions options
)

Parameters

options DirectShapeOptions
The options object.

Return Value

Boolean
True if the DirectShapeOptions are valid; false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also