Create Method


Level Create Method

Creates a new instance of level based on an input elevation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static Level Create(
	Document document,
	double elevation
)

Parameters

document Document
The document in which the new instance is created
elevation Double
The elevation of the level to be created.

Return Value

Level
The newly created level instance.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Example
Level CreateLevel(Autodesk.Revit.DB.Document document)
{
    // The elevation to apply to the new level
    double elevation = 20.0; 

    // Begin to create a level
    Level level = Level.Create(document, elevation);
    if (null == level)
    {
        throw new Exception("Create a new level failed.");
    }

    // Change the level name
    level.Name = "New level";

    return level;
}
See Also