Create Method (Document, ElementId, ElementId, ElementId, XYZ, XYZ, IList(XYZ))


Flex Duct Create(Document, Element Id, Element Id, Element Id, XYZ, XYZ, IList XYZ ) Method

Creates a new flexible duct into the document, using a point array and flexible duct type.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static FlexDuct Create(
	Document document,
	ElementId systemTypeId,
	ElementId ductTypeId,
	ElementId levelId,
	XYZ startTangent,
	XYZ endTangent,
	IList<XYZ> points
)

Parameters

document Document
The document.
systemTypeId ElementId
The id of the HVAC system type.
ductTypeId ElementId
The id of the flexible duct.
levelId ElementId
The level id for the flexible duct.
startTangent XYZ
The tangent vector at the start of the curve. The invalid or zero vector is ignored.
endTangent XYZ
The tangent vector at the end of the curve. The invalid or zero vector is ignored.
points IList XYZ
The point array indicating the path of the flexible duct, including the end point.

Return Value

FlexDuct
If creation was successful then a new flexible duct is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception Condition
ArgumentException The systemTypeId is not valid HVAC system type. -or- The type ductTypeId is not valid flexible duct type. -or- The ElementId levelId is not a Level. -or- The valid number of points is less than two. In order to create a flex curve, at least two points are required. Note the duplicate points don't take into account.
ArgumentNullException A non-optional argument was null
See Also