MathComparisonUtils Class


Math Comparison Utils Class

This class contains a set of mathematical utilities to compare doubles, using the internal tolerance.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB MathComparisonUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class MathComparisonUtils

The MathComparisonUtils type exposes the following members.

Methods
Name Description
Public method Static member IsAlmostEqual Checks if two doubles are almost equal, using the internal tolerance.
Public method Static member IsAlmostZero Checks if value is almost zero, using the internal tolerance.
Public method Static member IsGreaterThan Checks if value1 is strictly greater than value2, using the internal tolerance.
Public method Static member IsGreaterThanOrAlmostEqual Checks if value1 is greater than or almost equal to value2, using the internal tolerance.
Public method Static member IsLessThan Checks if value1 is strictly less than value2, using the internal tolerance.
Public method Static member IsLessThanOrAlmostEqual Checks if value1 is less than or almost equal to value2, using the internal tolerance.
Top
See Also