Math |
This class contains a set of mathematical utilities to compare doubles, using the internal tolerance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The MathComparisonUtils type exposes the following members.

Name | Description | |
---|---|---|
![]() ![]() | IsAlmostEqual | Checks if two doubles are almost equal, using the internal tolerance. |
![]() ![]() | IsAlmostZero | Checks if value is almost zero, using the internal tolerance. |
![]() ![]() | IsGreaterThan | Checks if value1 is strictly greater than value2, using the internal tolerance. |
![]() ![]() | IsGreaterThanOrAlmostEqual | Checks if value1 is greater than or almost equal to value2, using the internal tolerance. |
![]() ![]() | IsLessThan | Checks if value1 is strictly less than value2, using the internal tolerance. |
![]() ![]() | IsLessThanOrAlmostEqual | Checks if value1 is less than or almost equal to value2, using the internal tolerance. |