UnifiedBitmap Class


Unified Bitmap Class

A static class that provides access to the property names that appear in the UnifiedBitmap visual asset schema.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Visual UnifiedBitmap

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class UnifiedBitmap

The UnifiedBitmap type exposes the following members.

Properties
Name Description
Public property Static member TextureLinkTextureTransforms The property labeled "Link texture Transforms" from the "UnifiedBitmap" schema.
Public property Static member TextureOffsetLock The property labeled "Offset Lock" from the "UnifiedBitmap" schema.
Public property Static member TextureRealWorldOffsetX The property labeled "Offset X" from the "UnifiedBitmap" schema.
Public property Static member TextureRealWorldOffsetY The property labeled "Offset Y" from the "UnifiedBitmap" schema.
Public property Static member TextureRealWorldScaleX The property labeled "Size X" from the "UnifiedBitmap" schema.
Public property Static member TextureRealWorldScaleY The property labeled "Size Y" from the "UnifiedBitmap" schema.
Public property Static member TextureScaleLock The property labeled "Scale Lock" from the "UnifiedBitmap" schema.
Public property Static member TextureURepeat The property labeled "U Repeat" from the "UnifiedBitmap" schema.
Public property Static member TextureVRepeat The property labeled "V Repeat" from the "UnifiedBitmap" schema.
Public property Static member TextureWAngle The property labeled "Angle" from the "UnifiedBitmap" schema.
Public property Static member UnifiedbitmapBitmap The property labeled "Source" from the "UnifiedBitmap" schema.
Public property Static member UnifiedbitmapInvert The property labeled "Invert Image" from the "UnifiedBitmap" schema.
Public property Static member UnifiedbitmapRGBAmount The property labeled "Brightness" from the "UnifiedBitmap" schema.
Top
See Also