Unified |
A static class that provides access to the property names that appear in the UnifiedBitmap visual asset schema.

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The UnifiedBitmap type exposes the following members.

Name | Description | |
---|---|---|
![]() ![]() | TextureLinkTextureTransforms | The property labeled "Link texture Transforms" from the "UnifiedBitmap" schema. |
![]() ![]() | TextureOffsetLock | The property labeled "Offset Lock" from the "UnifiedBitmap" schema. |
![]() ![]() | TextureRealWorldOffsetX | The property labeled "Offset X" from the "UnifiedBitmap" schema. |
![]() ![]() | TextureRealWorldOffsetY | The property labeled "Offset Y" from the "UnifiedBitmap" schema. |
![]() ![]() | TextureRealWorldScaleX | The property labeled "Size X" from the "UnifiedBitmap" schema. |
![]() ![]() | TextureRealWorldScaleY | The property labeled "Size Y" from the "UnifiedBitmap" schema. |
![]() ![]() | TextureScaleLock | The property labeled "Scale Lock" from the "UnifiedBitmap" schema. |
![]() ![]() | TextureURepeat | The property labeled "U Repeat" from the "UnifiedBitmap" schema. |
![]() ![]() | TextureVRepeat | The property labeled "V Repeat" from the "UnifiedBitmap" schema. |
![]() ![]() | TextureWAngle | The property labeled "Angle" from the "UnifiedBitmap" schema. |
![]() ![]() | UnifiedbitmapBitmap | The property labeled "Source" from the "UnifiedBitmap" schema. |
![]() ![]() | UnifiedbitmapInvert | The property labeled "Invert Image" from the "UnifiedBitmap" schema. |
![]() ![]() | UnifiedbitmapRGBAmount | The property labeled "Brightness" from the "UnifiedBitmap" schema. |