AssociateRegionWithLayer Method


Compound Structure Associate Region With Layer Method

Associates a region with a layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void AssociateRegionWithLayer(
	int regionId,
	int layerIdx
)

Parameters

regionId Int32
The id of a region.
layerIdx Int32
The index of a layer in this CompoundStructure.
Exceptions
Exception Condition
ArgumentException It is not a valid region id.
ArgumentOutOfRangeException The layer index is out of range.
InvalidOperationException This operation is valid only for vertically compound structures.
See Also