AssociateRegionWithLayer Method


Compound Structure Associate Region With Layer Method

Associates a region with a layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public void AssociateRegionWithLayer(
	int regionId,
	int layerIdx
)

Parameters

regionId Int32
The id of a region.
layerIdx Int32
Index of a layer in the CompoundStructure. The layer index is zero based. It counts from the exterior of wall and from the top of roofs, floors and ceilings.
Exceptions
Exception Condition
ArgumentException It is not a valid region id.
ArgumentOutOfRangeException The layer index is out of range.
InvalidOperationException This operation is valid only for vertically compound structures.
See Also