HasExternalGeometry Method


Direct Shape Has External Geometry Method

Checks whether the externally tagged geometry is already present in this DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool HasExternalGeometry(
	ExternalGeometryId externalId
)

Parameters

externalId ExternalGeometryId
The external ID of the externally tagged geometry to check.

Return Value

Boolean
True if such an externally tagged geometry is already present in this DirectShape, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also