ArePointsDistinct Method


Topography Surface Are Points Distinct Method

Identify whether the input points are distinct in XY location.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool ArePointsDistinct(
	IList<XYZ> points
)

Parameters

points IList XYZ
The points set to be checked.

Return Value

Boolean
True if all points are distinct after ignoring the elevations, otherwise false.
Exceptions
Exception Condition
ArgumentException There are no points in the input points set.
ArgumentNullException A non-optional argument was null
See Also