ElectricalPerPhaseData Class


Electrical Per Phase Data Class

This class represents per phase values including current and load.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Electrical ElectricalPerPhaseData

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ElectricalPerPhaseData : IDisposable

The ElectricalPerPhaseData type exposes the following members.

Properties
Name Description
Public property CurrentPhaseA The value of current on electrical phase A.
Public property CurrentPhaseB The value of current on electrical phase B.
Public property CurrentPhaseC The value of current on electrical phase C.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ElectricalPerPhaseData
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also