Electrical
|
This class represents per phase values including current and power.

System
Object
Autodesk.Revit.DB.Electrical ElectricalPerPhaseData
Autodesk.Revit.DB.Electrical ElectricalPerPhaseData
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

The ElectricalPerPhaseData type exposes the following members.

Name | Description | |
---|---|---|
![]() |
CurrentPhaseA | The effective value of current on electrical phase A. |
![]() |
CurrentPhaseB | The effective value of current on electrical phase B. |
![]() |
CurrentPhaseC | The effective value of current on electrical phase C. |
![]() |
IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() |
Dispose | Releases all resources used by the ElectricalPerPhaseData |
![]() |
Equals |
Determines whether the specified object is equal to the current object.
(Inherited from Object ) |
![]() |
GetHashCode |
Serves as the default hash function.
(Inherited from Object ) |
![]() |
GetType |
Gets the
Type
of the current instance.
(Inherited from Object ) |
![]() |
ToString |
Returns a string that represents the current object.
(Inherited from Object ) |