ScheduleFieldId Class


Schedule Field Id Class

The ScheduleFieldId object is used as a unique identification for a field in a schedule.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ScheduleFieldId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ScheduleFieldId

The ScheduleFieldId type exposes the following members.

Constructors
Name Description
Public method ScheduleFieldId Initializes a new instance of the ScheduleFieldId class
Top
Properties
Name Description
Public property IntegerValue Provides the value of the ScheduleFieldId as an integer.
Public property Static member InvalidScheduleFieldId Get the invalid ScheduleFieldId whose IntegerValue is -1.
Top
Methods
Name Description
Public method Equals Determines whether the specified Object is equal to the current Object .
(Overrides Object Equals(Object) )
Public method GetHashCode Gets the integer value of the id as hash code
(Overrides Object GetHashCode )
Public method ToString Gets a String representation of the integer value of the id.
(Overrides Object ToString )
Top
Operators
Name Description
Public operator Static member Equality(ScheduleFieldId, ScheduleFieldId) Determines whether two ScheduleFieldIds are the same.
Public operator Static member Inequality(ScheduleFieldId, ScheduleFieldId) Determines whether two ScheduleFieldId are different.
Top
See Also