Schedule |
The ScheduleFieldId object is used as a unique identification for a field in a schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The ScheduleFieldId type exposes the following members.

Name | Description | |
---|---|---|
![]() | ScheduleFieldId | Initializes a new instance of the ScheduleFieldId class |

Name | Description | |
---|---|---|
![]() | IntegerValue | Provides the value of the ScheduleFieldId as an integer. |
![]() ![]() | InvalidScheduleFieldId | Get the invalid ScheduleFieldId whose IntegerValue is -1. |

Name | Description | |
---|---|---|
![]() | Equals | Determines whether the specified Object is equal to the current Object . (Overrides Object Equals(Object) ) |
![]() | GetHashCode | Gets the integer value of the id as hash code (Overrides Object GetHashCode ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Gets a String representation of the integer value of the id. (Overrides Object ToString ) |

Name | Description | |
---|---|---|
![]() ![]() | Equality(ScheduleFieldId, ScheduleFieldId) | Determines whether two ScheduleFieldIds are the same. |
![]() ![]() | Inequality(ScheduleFieldId, ScheduleFieldId) | Determines whether two ScheduleFieldId are different. |