AddFabricationInformationForRevitElements Method


Steel Element Properties Add Fabrication Information For Revit Elements Method

This method adds fabrication information to the given elements.

Namespace: Autodesk.Revit.DB.Steel
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static IList<ElementId> AddFabricationInformationForRevitElements(
	Document aDoc,
	IList<ElementId> elementIds
)

Parameters

aDoc Document
Document containing the given elements ids.
elementIds IList ElementId
Ids of the elements to which we want to add fabrication information.

Return Value

IList ElementId
Ids of the elements for which we couldn't add fabrication information.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
You can add fabrication information to connections, beams, columns, braces, walls, floors and foundations.
See Also