IsModifiableSpec Method


Units Is Modifiable Spec Method

Checks whether the default FormatOptions can be modified for a given spec.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsModifiableSpec(
	ForgeTypeId specTypeId
)

Parameters

specTypeId ForgeTypeId
Identifier of the spec to check.

Return Value

Boolean
True if the FormatOptions can be modified, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
The Units class stores a FormatOptions object for every spec, but not all of them can be directly modified. Some have fixed definitions.
See Also