Form Rotate Sub Element Method Rotate a face/edge/curve/vertex of the form, by a specified angle around a given axis. Namespace: Autodesk.Revit.DB Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0) Syntax C# VB C++ F# public void RotateSubElement( Reference subElementReference, Line axis, double angle ) Public Sub RotateSubElement ( subElementReference As Reference, axis As Line, angle As Double ) public: void RotateSubElement( Reference^ subElementReference, Line^ axis, double angle ) member RotateSubElement : subElementReference : Reference * axis : Line * angle : float -> unit Parameters subElementReference Reference The geometry reference of face/edge/curve/vertex axis Line An unbounded line that represents the axis of rotation. angle Double The angle, in radians, by which the element is to be rotated around the specified axis. See Also Reference Form Class Autodesk.Revit.DB Namespace
Form Rotate Sub Element Method Rotate a face/edge/curve/vertex of the form, by a specified angle around a given axis. Namespace: Autodesk.Revit.DB Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0) Syntax C# VB C++ F# public void RotateSubElement( Reference subElementReference, Line axis, double angle ) Public Sub RotateSubElement ( subElementReference As Reference, axis As Line, angle As Double ) public: void RotateSubElement( Reference^ subElementReference, Line^ axis, double angle ) member RotateSubElement : subElementReference : Reference * axis : Line * angle : float -> unit Parameters subElementReference Reference The geometry reference of face/edge/curve/vertex axis Line An unbounded line that represents the axis of rotation. angle Double The angle, in radians, by which the element is to be rotated around the specified axis. See Also Reference Form Class Autodesk.Revit.DB Namespace