RotateSubElement Method


Form Rotate Sub Element Method

Rotate a face/edge/curve/vertex of the form, by a specified angle around a given axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void RotateSubElement(
	Reference subElementReference,
	Line axis,
	double angle
)

Parameters

subElementReference Reference
The geometry reference of face/edge/curve/vertex
axis Line
An unbounded line that represents the axis of rotation.
angle Double
The angle, in radians, by which the element is to be rotated around the specified axis.
See Also