ExternalCommandData Class


External Command Data Class

A class contains reference to Application and View which are needed by external command.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.UI ExternalCommandData

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExternalCommandData : APIObject

The ExternalCommandData type exposes the following members.

Properties
Name Description
Public property Application Retrieves an object that represents the current Application for external command.
Public property Code example IsReadOnly Identifies if the object is read-only or modifiable.
(Inherited from APIObject )
Public property Code example JournalData A data map that can be used to read and write data to the Autodesk Revit journal file.
Public property View Retrieves an object that represents the View external command work on.
Top
Methods
Name Description
Public method Dispose Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also