Create Method (Document, IList(ElementId), String)


Structural Connection Handler Create(Document, IList Element Id , String) Method

Creates custom StructuralConnectionHandlerType and StructuralConnectionHandler.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static StructuralConnectionHandler Create(
	Document document,
	IList<ElementId> elementIds,
	string typeName
)

Parameters

document Document
The Document.
elementIds IList ElementId
Elements which are to be used to create custom StructuralConnectionHandlerType.
typeName String
The StructuralConnectionHandlerType name.

Return Value

StructuralConnectionHandler
The created StructuralConnectionHandler which is of just created custom StructuralConnectionHandlerType.
Exceptions
Exception Condition
ArgumentException All the input Elements should be of the following structural categories: framings, columns, profiles, plates, bolts, anchors, shear studs, welds or structural connections. -or- There must be at least one StructuralConnectionHandler among the input Elements. Total number of different input elements of input StructuralConnectionHandlers must be lower or equal to 3. -or- Name must be unique among other existing StructuralConnectionHandlerTypes and cannot contain invalid characters.
ArgumentNullException A non-optional argument was null
ModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException The document has no open transaction.
Remarks
Input Elements are deleted. All the input elements should be of the following structural categories:
  • FamilyInstance (structural beams and columns).
  • StructuralConnectionHandler elements associated to the connection.
  • Specific steel connection elements (bolts, anchors, plates, etc). These connection elements will be of type element but with categories related to structural connections, for example:
    • OST_StructConnectionWelds
    • OST_StructConnectionHoles
    • OST_StructConnectionModifiers
    • OST_StructConnectionShearStuds
    • OST_StructConnectionBolts
    • OST_StructConnectionAnchors
    • OST_StructConnectionPlates
See Also