GradientBackgroundSettings Class


Gradient Background Settings Class

Represents the view gradient background settings.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BackgroundSettings
Autodesk.Revit.DB GradientBackgroundSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class GradientBackgroundSettings : BackgroundSettings

The GradientBackgroundSettings type exposes the following members.

Properties
Name Description
Public property GroundColor The color of the ground.
Public property HorizonColor The color of the horizon.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from BackgroundSettings )
Public property SkyColor The color of the top of the sky.
Top
Methods
Name Description
Public method Dispose
(Inherited from BackgroundSettings )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
The colors of the background are interpolated for the pixels corresponding to the sky - from the "sky color" (top) to the "horizon color" (bottom). The ground is represented with a solid color ("ground color").
See Also