WorksetConfiguration Class


Workset Configuration Class

A configuration class that is passed in to methods that open Revit documents to specify which user-created worksets are opened/closed.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB WorksetConfiguration

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class WorksetConfiguration : IDisposable

The WorksetConfiguration type exposes the following members.

Constructors
Name Description
Public method WorksetConfiguration Constructs a new workset configuration with an initial setting to open all user-created worksets.
Public method WorksetConfiguration(WorksetConfiguration) Constructs a new copy of the input WorksetConfiguration object.
Public method WorksetConfiguration(WorksetConfigurationOption) Constructs a new workset configuration with an initial setting to open or close all user-created worksets, or to open last viewed worksets.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Close Sets a group of user-created worksets to close.
Public method Dispose Releases all resources used by the WorksetConfiguration
Public method Open Sets a group of user-created worksets to open.
Top
Remarks

Once an instance of this class is created, it can be further modified by calling any of the other methods in any order. It is a specification of a setting for model open; the methods of this class just adjust the specification, and do not themselves open or close worksets.

Only user-created worksets can be specified to be opened or closed. All system worksets are automatically open. An open workset allows its elements can be expanded and displayed. For a closed workset, Revit tries to not expand its elements, and to that end, does not display them. This is intended to help with performance by reducing Revit's memory footprint.

See Also