Workset |
A configuration class that is passed in to methods that open Revit documents to specify which user-created worksets are opened/closed.

System Object
Autodesk.Revit.DB WorksetConfiguration
Autodesk.Revit.DB WorksetConfiguration
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The WorksetConfiguration type exposes the following members.

Name | Description | |
---|---|---|
![]() | WorksetConfiguration | Constructs a new workset configuration with an initial setting to open all user-created worksets. |
![]() | WorksetConfiguration(WorksetConfiguration) | Constructs a new copy of the input WorksetConfiguration object. |
![]() | WorksetConfiguration(WorksetConfigurationOption) | Constructs a new workset configuration with an initial setting to open or close all user-created worksets, or to open last viewed worksets. |

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Close | |
![]() | Dispose | Releases all resources used by the WorksetConfiguration |
![]() | Open | |

Once an instance of this class is created, it can be further modified by calling any of the other methods in any order. It is a specification of a setting for model open; the methods of this class just adjust the specification, and do not themselves open or close worksets.
Only user-created worksets can be specified to be opened or closed. All system worksets are automatically open. An open workset allows its elements can be expanded and displayed. For a closed workset, Revit tries to not expand its elements, and to that end, does not display them. This is intended to help with performance by reducing Revit's memory footprint.