CreateMultiPlaneFilter Method (IList(Plane))


Point Cloud Filter Factory Create Multi Plane Filter(IList Plane ) Method

Creates a new point cloud filter based upon planar boundaries.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static PointCloudFilter CreateMultiPlaneFilter(
	IList<Plane> planes
)

Parameters

planes IList Plane
All planes used for filtering; positive direction of the normal should point inside the volume of interest. Only points on the "positive" side of all planes will pass the filter.

Return Value

PointCloudFilter
Filter object; can be used to get representative set of cloud points passing through the filter.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
The filter will check whether a point is located on the "positive" side of each plane, as indicated by the positive direction of the plane normal. Therefore, such filter implicitly defines a volume, which is the intersection of the positive half-spaces corresponding to all the planes. This volume does not have to be closed, but it will always be convex.
See Also